CVE-2026-77414: jsonata · Code Injection
Affects jsonataSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 2.2.1 or 1.8.8 as a priority.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.1, 1.8.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade jsonata to 2.2.1 or 1.8.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| jsonata-jsjsonata | Affected
| Fixed in
|
| jsonata-jsjsonata | Affected
| Fixed in
|
npmjsonatapkg:npm/jsonataOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade jsonata-js to version 1.8.8 or later, or 2.2.1 or later, where this vulnerability is fixed. No other mitigations are indicated or required by the vendor advisory.
Description
CVE-2026-77414 is a critical code injection vulnerability in the jsonata-js library, a JSON query and transformation language. Versions prior to 1.8.8 and 2.2.1 contain a flaw in the environment.lookup function where a bypassable hasOwnProperty check allows crafted expressions to access the object prototype and execute arbitrary code via process.getBuiltinModule with child_process. This vulnerability enables attackers to execute code with the privileges of the host process. The issue is fixed in jsonata versions 1.8.8 and 2.2.1.
References
- github.com/jsonata-js/jsonata/security/advisories/GHSA-2943-5xfg-gq5f (opens in a new tab)
- github.com/jsonata-js/jsonata/pull/799 (opens in a new tab)
- github.com/jsonata-js/jsonata/commit/59e25144fc3b7125f6befd71b8a6e14e1fa610d2 (opens in a new tab)
- github.com/jsonata-js/jsonata/releases/tag/v1.8.8 (opens in a new tab)
- github.com/jsonata-js/jsonata/releases/tag/v2.2.1 (opens in a new tab)