CVE-2026-77705: Booking for Appointments and Events Calendar (WordPress plugin) · Insecure Direct Object Reference
Affects Booking for Appointments and Events Calendar (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.2 High : upgrade to 2.4.10 soon.
Data as of 27 Oct 2026, 17:11 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.10
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Booking for Appointments and Events Calendar (WordPress plugin) to 2.4.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Booking for Appointments and Events Calendar | Affected
| Fixed in
|
AI-suggested
Upgrade the Booking for Appointments and Events Calendar plugin to version 2.4.10 or later, where this authorization bypass vulnerability is fixed. No other mitigation is indicated.
Description
The Booking for Appointments and Events Calendar WordPress plugin before 2.4.10 does not verify that the user editing a customer or employee record is entitled to modify the WordPress account linked to it, allowing users holding Amelia's customer or employee management permissions to set the password and email address of other users' WordPress accounts and take them over.