CVE-2026-77791: Apache Tomcat · Uncontrolled Resource Consumption
Affects Apache TomcatSource CVE Database V5
Not known to be exploited · CVSS 7.5 High · end of life, no fix coming : replace or isolate Apache Tomcat; no fix will be released.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- None coming – the product is end of life
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
No fix will be released: Apache Tomcat is end of life. Replace it, or isolate it from untrusted networks until you can.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Tomcat | Affected
| Fixed in– |
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Tomcat to versions 11.0.26, 10.1.60, or 9.0.122, which contain fixes for this vulnerability. Applying these official updates is the recommended and effective mitigation. No other specific mitigations are indicated.
Description
CVE-2026-77791 is an Uncontrolled Resource Consumption vulnerability in Apache Tomcat that allows a denial-of-service (DoS) attack during the sending of WebSocket close messages. This affects multiple Apache Tomcat versions, including 11.0.0-M5 through 11.0.25, 10.1.8 through 10.1.59, 9.0.74 through 9.0.121, and some end-of-life versions 8.5.88 through 8.5.100. Users are advised to upgrade to fixed versions 11.0.26, 10.1.60, or 9.0.122 to mitigate the issue. The vulnerability has a CVSS score of 7.5, indicating high severity.