Skip to main content
CVE-2024-54677VulnerabilityPublished Updated

CVE-2024-54677: Apache Tomcat · Uncontrolled Resource Consumption

Affects Apache TomcatSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium · fixed in 11.0.2 : update Apache Tomcat when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.9% chance of exploitation in 30 days – higher than 79% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.0.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threatsAffected
  • =11.0.0-M1
  • =10.1.0-M1
  • >=8.5.0 <=8.5.100
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade affected Apache Tomcat instances to versions 11.0.2, 10.1.34, or 9.0.98 where this vulnerability is fixed. No other mitigations are specified. Patch status is confirmed by the vendor advisory embedded in the CVE description.

Description

An uncontrolled resource consumption vulnerability exists in the examples web application of Apache Tomcat, leading to denial of service. This affects multiple versions including 11.0.0-M1 through 11.0.1, 10.1.0-M1 through 10.1.33, 9.0.0-M1 through 9.9.97, and 8.5.0 through 8.5.100. Users should upgrade to fixed versions 11.0.2, 10.1.34, or 9.0.98 to resolve the issue.

References

Community reviews

Loading reviews…