Skip to main content
VulnerabilityPublished

CVE-2026-7796: EmbedPress (WordPress plugin) · Cross-site Scripting

Affects EmbedPress (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.4 Medium.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
wpdevteamEmbedPress – PDF Embedder, Embed PDF viewer, YouTube Videos, 3D FlipBook, Social feeds & moreAffected
  • <=4.5.3
Fixed in–

AI-suggested

Users should check the vendor's advisory or plugin updates for fixes beyond version 4.5.3. Until a fix is available, restrict contributor-level access carefully and consider disabling or removing the plugin if possible to mitigate risk.

Description

EmbedPress – PDF Embedder, Embed PDF viewer, YouTube Videos, 3D FlipBook, Social feeds & more WordPress plugin versions up to and including 4.5.3 contain a stored cross-site scripting (XSS) vulnerability. The issue arises from insufficient sanitization and escaping of the 'url' attribute in a block, allowing authenticated users with contributor-level access or higher to inject malicious scripts. These scripts execute when any user views the affected page. The vulnerability has a medium severity rating with a CVSS score of 6.4.

References

Community reviews

Loading reviews…