CVE-2026-7813: pgAdmin 4 · Improper Access Control
Affects pgAdmin 4Source CVE Database V5
Not known to be exploited · CVSS 9.9 Critical : upgrade to 9.15 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.15
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 11 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade pgadmin-org/pgadmin4 and pgAdmin 4 to 9.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pgadmin.orgpgAdmin 4 | Affected
| Fixed in– |
GitHubpgadmin-org/pgadmin4pkg:github/pgadmin-org/pgadmin4Other threats | Affected
| Fixed in
|
GitHubpgAdmin 4pkg:github/pgAdmin 4Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The input data indicates that fixes have been implemented in pgAdmin 4 version 9.15 and later, which centralize access control and enforce strict owner-only permissions. Users should upgrade to version 9.15 or later once available. Until then, restrict access to pgAdmin 4 server mode to trusted users only and monitor for suspicious activity related to server and shared server management. No official vendor advisory or patch link is provided in the input data, so consult pgadmin.org for the latest updates.
Description
Authorization vulnerability in pgAdmin 4 server mode affecting Server Groups, Servers, Shared Servers, Background Processes, and Debugger modules. Multiple endpoints fetched user-owned objects without filtering by the requesting user's identity. An authenticated user could access another user's private servers, server groups, background processes, and debugger function arguments by guessing object IDs. Additionally, the Shared Servers feature contained multiple issues including credential leakage (passexec_cmd, passfile, SSL keys), privilege escalation via writable passexec_cmd (a shell command executed when establishing the connection) allowing arbitrary command execution in the owner's process context, and owner-data corruption via SQLAlchemy session mutations. Several owner-only fields (passexec_cmd, passexec_expiration, db_res, db_res_type) were writable by non-owners through the API, and additional fields (kerberos_conn, tags, post_connection_sql) lacked per-user persistence so non-owner edits mutated the owner's record. Fix centralises access control via a new server_access module, scopes all user-owned models with a UserScopedMixin, returns HTTP 410 from connection_manager when access is denied in server mode, suppresses owner-only fields for non-owners across the merge / API response / ServerManager paths, and adds an explicit owner-only write guard. The remediation landed in two pull requests; both are referenced. This issue affects pgAdmin 4: before 9.15.