Skip to main content
VulnerabilityPublished Updated

CVE-2026-7860: vaadin flow · Generation of Error Message Containing Sensitive Information

Affects vaadin flowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 1.6 Low · fixed in 25.1.5 : update vaadin flow when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
1.6Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 25.1.5, 25.0.12, 24.10.4 +2
CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:P/VC:H/VI:N/VA:N/SC:H/SI:H/SA:N/E:U/S:N/AU:N/R:A/V:C/RE:L/U:Green

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
vaadinflowAffected
  • >=23.0.0 <=23.6.10
  • >=24.0.0 <=24.9.17
  • >=24.10.0 <=24.10.3
  • >=25.0.0 <=25.0.11
  • >=25.1.0 <=25.1.4
Fixed in–
Mavenvaadin/com.vaadin:flow-plugin-basepkg:maven/vaadin/com.vaadin:flow-plugin-baseOther threatsAffected
  • >=23.0.0 <=23.6.10
  • >=24.0.0 <=24.9.17
  • >=24.10.0 <=24.10.3
  • >=25.0.0 <=25.0.11
  • >=25.1.0 <=25.1.4
Fixed in–
Mavenvaadin/com.vaadin:flow-maven-pluginpkg:maven/vaadin/com.vaadin:flow-maven-pluginOther threatsAffected
  • >=23.0.0 <=23.6.10
  • >=24.0.0 <=24.9.17
  • >=24.10.0 <=24.10.3
  • >=25.0.0 <=25.0.11
  • >=25.1.0 <=25.1.4
Fixed in–
Mavenvaadin/com.vaadin:flow-gradle-pluginpkg:maven/vaadin/com.vaadin:flow-gradle-pluginOther threatsAffected
  • >=23.0.0 <=23.6.10
  • >=24.0.0 <=24.9.17
  • >=24.10.0 <=24.10.3
  • >=25.0.0 <=25.0.11
  • >=25.1.0 <=25.1.4
Fixed in–
Mavencom.vaadin/flow-plugin-basepkg:maven/com.vaadin/flow-plugin-baseOther threatsAffected
  • >=23.0.0 <23.6.11
  • >=24.0.0 <24.9.18
  • >=24.10.0 <24.10.4
  • >=25.0.0 <25.0.12
  • >=25.1.0 <25.1.5
Fixed in
  • 23.6.11
  • 24.9.18
  • 24.10.4
  • 25.0.12
  • 25.1.5
Mavencom.vaadin/flow-maven-pluginpkg:maven/com.vaadin/flow-maven-pluginOther threatsAffected
  • >=23.0.0 <23.6.11
  • >=24.0.0 <24.9.18
  • >=24.10.0 <24.10.4
  • >=25.0.0 <25.0.12
  • >=25.1.0 <25.1.5
Fixed in
  • 23.6.11
  • 24.9.18
  • 24.10.4
  • 25.0.12
  • 25.1.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade to one of the fixed versions: 23.6.11 or newer for Vaadin 23, 24.9.18 or newer for Vaadin 24, 24.10.4 or newer for Vaadin 24.10, 25.0.12 or newer for Vaadin 25.0, and 25.1.5 or newer for Vaadin 25.1. Vaadin versions 10-13 and 15-22 are no longer supported and should be upgraded to the latest supported versions. Applying these upgrades will prevent sensitive environment variables from being exposed in build failure logs.

Description

A possible information disclosure vulnerability exists in the Vaadin Maven plugin and Vaadin Gradle plugin that exposes the full set of environment variables in build logs whenever the frontend build process exits with a non-zero status. Because the build environment may contain credentials supplied as secrets, any failed frontend build can expose those secrets in clear text in CI logs and archived build artifacts. Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include: Product version Vaadin 23.0.0 - 23.6.9 Vaadin 24.0.0 - 24.9.16 Vaadin 24.10.0 - 24.10.3 Vaadin 25.0.0 - 25.0.10 Vaadin 25.1.0 - 25.1.4 Mitigation Upgrade to 23.6.10 Upgrade to 24.9.17 or newer Upgrade to 24.10.4 or newer Upgrade to 25.0.11 or newer Upgrade to 25.1.5 or newer Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 23, 24, or 25 version. ArtifactsMaven coordinatesVulnerable versionsFixed versioncom.vaadin:flow-plugin-base23.0.0 - 23.6.10≥23.6.11com.vaadin:flow-plugin-base24.0.0 - 24.9.17≥24.9.18com.vaadin:flow-plugin-base24.10.0 - 24.10.3≥24.10.4com.vaadin:flow-plugin-base25.0.0 - 25.0.11≥25.0.12com.vaadin:flow-plugin-base25.1.0 - 25.1.4≥25.1.5com.vaadin:flow-maven-plugin23.0.0 - 23.6.10≥23.6.11com.vaadin:flow-maven-plugin24.0.0 - 24.9.17≥24.9.18com.vaadin:flow-maven-plugin24.10.0 - 24.10.3≥24.10.4com.vaadin:flow-maven-plugin25.0.0 - 25.0.11≥25.0.12com.vaadin:flow-maven-plugin25.1.0 - 25.1.4≥25.1.5com.vaadin:flow-gradle-plugin23.0.0 - 23.6.10≥23.6.11com.vaadin:flow-gradle-plugin24.0.0 - 24.9.17≥24.9.18com.vaadin:flow-gradle-plugin24.10.0 - 24.10.3≥24.10.4com.vaadin:flow-gradle-plugin25.0.0 - 25.0.11≥25.0.12com.vaadin:flow-gradle-plugin25.1.0 - 25.1.4≥25.1.5

References

Community reviews

Loading reviews…