CVE-2026-80342: Payment Plugins for PayPal WooCommerce (WordPress plugin) · Insecure Direct Object Reference
Affects Payment Plugins for PayPal WooCommerce (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.0.27 when convenient.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.27
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade Payment Plugins for PayPal WooCommerce (WordPress plugin) to 2.0.27.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Payment Plugins for PayPal WooCommerce | Affected
| Fixed in
|
AI-suggested
Upgrade the Payment Plugins for PayPal WooCommerce plugin to version 2.0.27 or later where this vulnerability is fixed. No other mitigation or temporary fix is indicated.
Description
The Payment Plugins for PayPal WooCommerce WordPress plugin before 2.0.27 does not verify that a PayPal order supplied in a payment request belongs to the WooCommerce order being paid unless that PayPal order has already been completed, allowing unauthenticated attackers to have another buyer's approved but uncaptured payment captured against an order of their own.