Skip to main content
VulnerabilityPublished

CVE-2026-80351: Apache Camel K · Eval Injection

Affects Apache Camel KSource CVE Database V5

0

Not known to be exploited · CVSS 9.8 Critical : upgrade to 2.10.2 or 2.9.3 as a priority.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers can reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-09-10.

Patch
Available – fixed in 2.10.2, 2.9.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache Camel K to 2.10.2 or 2.9.3.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Camel KAffected
  • >=2.10.1 <2.10.2
Fixed in
  • 2.10.2
Apache Software FoundationApache Camel KAffected
  • >=2.0.0 <2.9.3
Fixed in
  • 2.9.3

AI-suggested

Users should upgrade affected Apache Camel K versions to 2.9.3, 2.10.2, or 2.11.0, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated by the vendor advisory.

Description

CVE-2026-80351 is a critical eval injection vulnerability in Apache Camel K that allows tenant-controlled Maven repository content to influence code execution within the operator pod. This improper neutralization of directives in dynamically evaluated Maven configuration can lead to arbitrary code execution with operator privileges. Versions from 2.0.0 up to but not including 2.9.3, and from 2.10.1 up to but not including 2.10.2 are affected. The issue is fixed in versions 2.9.3, 2.10.2, and 2.11.0.

References

Community reviews

Loading reviews…