CVE-2026-81176: sveltejs devalue · Unthrottled Resource Allocation
Affects sveltejs devalueSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 5.9.2 when convenient.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.9.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade sveltejs devalue to 5.9.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| sveltejsdevalue | Affected
| Fixed in
|
npmdevaluepkg:npm/devalueOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to sveltejs devalue version 5.9.2 or later, where this vulnerability is fixed. No other mitigations are specified or required.
Description
CVE-2026-81176 is a denial of service vulnerability in the sveltejs devalue JavaScript library prior to version 5.9.2. The issue arises because devalue.parse does not reject out-of-bounds indices, leading to excessive computational work when parsing specially crafted untrusted payloads. This can cause applications using vulnerable versions to experience performance degradation or denial of service. The vulnerability is fixed in version 5.9.2.