CVE-2026-81754: Vigilant (WordPress plugin) · Cross-site Scripting
Affects Vigilant (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.2 High · fixed in 2.10.2 : patch Vigilant (WordPress plugin) soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.10.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 11 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| fernandotVigilant – 100% Free Security Suite: Firewall, 2FA, Login, Headers, Scanner… | Affected
| Fixed in– |
AI-suggested
A fix is available in versions later than 2.10.2. Users should upgrade the Vigilant plugin to a version higher than 2.10.2 once released. Until then, consider restricting or sanitizing User-Agent headers at the web server or application firewall level as a temporary mitigation. Monitor the vendor advisory for official patch releases.
Description
The Vigilant – 100% Free Security Suite: Firewall, 2FA, Login, Headers, Scanner… plugin for WordPress is vulnerable to Stored Cross-Site Scripting via User-Agent Header in all versions up to, and including, 2.10.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The malicious payload is delivered passively by any unauthenticated visitor who triggers a failed login attempt with a crafted User-Agent header, requiring no further interaction from the attacker once stored.
References
- wordfence.com/threat-intel/vulnerabilities/id/c483cdc5-56e4-4ee7-a782-0505816728ab?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/vigilante/tags/2.9.5/includes/class-database.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/vigilante/tags/2.9.5/includes/class-database.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/vigilante/tags/2.9.5/assets/js/admin.js (opens in a new tab)
- plugins.trac.wordpress.org/browser/vigilante/tags/2.9.5/assets/js/admin.js (opens in a new tab)
- plugins.trac.wordpress.org/browser/vigilante/tags/2.9.5/includes/class-login-security.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3669625%40vigilante%2Ftrunk%2Fassets%2Fjs%2Fadmin.js&old=3667821%40vigilante%2Ftrunk%2Fassets%2Fjs%2Fadmin.js&sfp_email=&sfph_mail= (opens in a new tab)