Skip to main content
VulnerabilityPublished Updated

CVE-2026-89160: PCRE PCRE2 · Out-of-bounds Read

Affects PCRE PCRE2Source CVE Database V5

0

Not known to be exploited · CVSS 3.7 Low : upgrade to 10.48 when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.48
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade PCRE2 and pcre2project/pcre2 to 10.48.

Affected software

ProductAffectedFixed in
PCREPCRE2Affected
  • >=10.34 <10.48
Fixed in
  • 10.48
GitHubpcre2project/pcre2pkg:github/pcre2project/pcre2Other threatsAffected
  • >=10.34 <10.48
Fixed in
  • 10.48

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in PCRE2 version 10.48 and later. Users should upgrade to version 10.48 or newer to remediate this vulnerability. Since this is not a cloud service, manual patching is required. No additional mitigation steps are indicated.

Description

CVE-2026-89160 is an out-of-bounds read vulnerability in PCRE2 versions from 10.34 up to but not including 10.48. It occurs during the PCRE2_MATCH_INVALID_UTF matching process when handling an invalid UTF subject. The vulnerability has a medium severity with a CVSS score of 3.7 and does not impact confidentiality or integrity but may affect availability.

References

Community reviews

Loading reviews…