Skip to main content
VulnerabilityPublished Updated

CVE-2026-89156: PCRE PCRE2 · Out-of-bounds Read

Affects PCRE PCRE2Source CVE Database V5

0

Not known to be exploited · CVSS 2.9 Low : upgrade to 10.48 when convenient.

Data as of 26 Oct 2026, 12:30 UTC

CVSS 3.1 base score
2.9Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.48
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade PCRE2 and pcre2project/pcre2 to 10.48.

Affected software

ProductAffectedFixed in
PCREPCRE2Affected
  • >=10.34 <10.48
Fixed in
  • 10.48
GitHubpcre2project/pcre2pkg:github/pcre2project/pcre2Other threatsAffected
  • >=10.34 <10.48
Fixed in
  • 10.48

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PCRE2 to version 10.48 or later, where this vulnerability and related memory safety issues have been fixed. No other mitigation is required as the vendor has provided an official fix. Patch status is confirmed by the vendor advisory indicating fixes in version 10.48.

Description

CVE-2026-89156 is an out-of-bounds read vulnerability in the PCRE2 library's pcre2_match function triggered after a JIT fallback when invalid UTF data is provided. PCRE2 is a C library for regular expression matching with separate 8-bit, 16-bit, and 32-bit APIs. This vulnerability affects versions from 10.34 up to but not including 10.48. The CVSS score is 2.9, indicating low severity for this specific issue. Multiple related vulnerabilities in PCRE2 before 10.48 address out-of-bounds reads and writes, integer overflows, and incorrect memory frees. The vendor has fixed these issues in version 10.48.

References

Community reviews

Loading reviews…