CVE-2026-82840: Apache Wicket · Session Fixation
Affects Apache WicketSource CVE Database V5
Not known to be exploited · CVSS 7.2 High.
Data as of 1 Nov 2026, 22:29 UTC
Thin evidence
One scorer or none| CNA (apache) | CVSS 4.0 | 7.2 |
|---|
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Wicketorg.apache.wicket:wicket-auth-roles | Affected
| Fixed in– |
Mavenorg.apache.wicket/wicket-auth-rolespkg:maven/org.apache.wicket/wicket-auth-rolesOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Wicket to versions 8.20.0, 9.25.0, or 10.12.0 where the vulnerability is fixed. As a workaround, applications can call Session#changeSessionId() explicitly after every successful authentication to ensure session ID renewal. Applications that already perform session ID renewal in their own code after authentication are not affected.
Description
CVE-2026-82840 is a session fixation vulnerability in Apache Wicket's authentication module. The flaw occurs because the session ID is only renewed on the first sign-in, not on subsequent authentications within an already signed-in session. This allows an attacker who can fix a session ID in a victim's browser to reuse that session after the victim re-authenticates, potentially bypassing session renewal protections. The issue affects Apache Wicket versions 8.18.0 through 8.19.0, 9.23.0 through 9.24.0, and 10.9.0 through 10.11.0. Upgrading to versions 8.20.0, 9.25.0, or 10.12.0 resolves the vulnerability.