CVE-2026-82355: Apache Airflow · Session Fixation
Affects Apache AirflowSource CVE Database V5
Not known to be exploited · CVSS 4.2 Medium : upgrade to 3.3.2 when convenient.
Data as of 5 Nov 2026, 11:40 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 4.2 |
|---|
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.3.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade Apache Airflow and org.apache.airflow/airflow-core and apache-airflow-core to 3.3.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Airflowapache-airflow-core | Affected
| Fixed in
|
Mavenorg.apache.airflow/airflow-corepkg:maven/org.apache.airflow/airflow-coreOther threats | Affected
| Fixed in
|
PyPIapache-airflow-corepkg:pypi/apache-airflow-coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users running Apache Airflow versions 3.3.0 or 3.3.1 should upgrade to version 3.3.2 or later, where the issue is fixed by correctly prioritizing the explicitly supplied bearer token over session cookies. Deployments on dedicated domains without co-hosted applications are less exposed. No additional mitigations are specified by the vendor advisory.
Description
Apache Airflow versions 3.3.0 and 3.3.1 contain a session fixation vulnerability where the system prioritizes a session cookie over an explicit Authorization Bearer token. This causes the API to authenticate the user based on the cookie rather than the token, leading to principal confusion and inaccurate audit logs. Exploitation requires an attacker to place a valid session cookie in the victim's browser, which is more feasible in environments sharing domains with other applications. The issue is fixed in version 3.3.2.