Skip to main content
VulnerabilityPublished Updated

CVE-2026-86473: Apache Airflow · DEPRECATED: Insufficient Session Expiration

Affects Apache AirflowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 3.3.2 as a priority.

Data as of 5 Nov 2026, 11:40 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.19.1
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.3.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Apache Airflow and apache-airflow and apache-airflow-core to 3.3.2.

Affected software

ProductAffectedFixed in
Apache Airflowapache-airflow-coreAffected
  • >=3.0.0 <3.3.2
Fixed in
  • 3.3.2
PyPIapache-airflowpkg:pypi/apache-airflowOther threatsAffected
  • >=3.0.0 <3.3.2
Fixed in
  • 3.3.2
PyPIapache-airflow-corepkg:pypi/apache-airflow-coreOther threatsAffected
  • >=3.0.0 <3.3.2
Fixed in
  • 3.3.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Airflow to version 3.3.2 or later, where this issue is fixed. No other mitigations are indicated. Users relying on bearer token authentication should ensure they apply this update to prevent token reuse after logout.

Description

Apache Airflow versions 3.0.0 through 3.3.1 have an insufficient session expiration vulnerability in the Core API logout endpoint. When API clients authenticate using a bearer token in the Authorization header, logging out does not revoke the token, allowing it to remain valid until its configured expiration (default 24 hours). An attacker with a copy of a valid token can maintain access after the victim logs out. This issue is fixed in Apache Airflow 3.3.2.

References

Community reviews

Loading reviews…