Skip to main content
VulnerabilityPublished

CVE-2026-95663: Apache Camel · Insufficient Session Expiration

Affects Apache CamelSource CVE Database V5

0

Not known to be exploited · CVSS 4.8 Medium : upgrade to 4.22.2 or 4.18.5 when convenient.

Data as of 26 Oct 2026, 14:18 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.22.2, 4.18.5
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache to 4.22.2 or 4.18.5.

Affected software

ProductAffectedFixed in
Apache Camelorg.apache.camel:camel-keycloakAffected
  • >=4.19.0 <4.22.2
Fixed in
  • 4.22.2
Apache Camelorg.apache.camel:camel-keycloakAffected
  • >=4.16.0 <4.18.5
Fixed in
  • 4.18.5
MavenApache Software Foundation/org.apache.camel:camel-keycloakpkg:maven/Apache Software Foundation/org.apache.camel:camel-keycloakOther threatsAffected
  • >=4.16.0 <4.18.5
  • >=4.19.0 <4.22.2
Fixed in
  • 4.18.5
  • 4.22.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Camel to version 4.23.0 or later. If upgrading immediately is not possible, users on the 4.22.x stream should upgrade to 4.22.2, and those on the 4.18.x stream should upgrade to 4.18.5. Versions 4.16.x, 4.17.x, and 4.19.x to 4.21.x are end-of-life and must be replaced with supported versions. As a temporary workaround, disable the introspection cache by setting introspectionCacheEnabled=false on the KeycloakSecurityPolicy to ensure every request is validated against the introspection endpoint, which correctly reports expired tokens as inactive. Lowering the cache TTL reduces but does not eliminate the vulnerability window.

Description

CVE-2026-95663 is an insufficient session expiration vulnerability in the Apache Camel Keycloak component affecting versions from 4.16.0 before 4.18.5 and from 4.19.0 before 4.22.2. When token introspection is enabled, the component caches token introspection results without respecting the token's expiration time, allowing expired tokens to be accepted for up to the cache's time-to-live. This can permit continued use of recently expired tokens for a short window, but does not allow token forgery or privilege escalation. The issue is fixed in Apache Camel versions 4.18.5 and 4.22.2.

References

Community reviews

Loading reviews…