Skip to main content
VulnerabilityPublished

CVE-2026-82851: Masteriyo LMS (WordPress plugin) · Insecure Direct Object Reference

Affects Masteriyo LMS (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 2.7 Low : upgrade to 3.4.1 when convenient.

Data as of 27 Oct 2026, 17:11 UTC

CVSS 3.1 base score
2.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Masteriyo LMS (WordPress plugin) to 3.4.1.

Affected software

ProductAffectedFixed in
Masteriyo LMSAffected
  • >=1.14.0 <3.4.1
Fixed in
  • 3.4.1

AI-suggested

Upgrade the Masteriyo LMS plugin to version 3.4.1 or later, where this authorization bypass vulnerability has been addressed. No other mitigation guidance is provided in the available data.

Description

The Masteriyo LMS WordPress plugin before 3.4.1 does not verify ownership of, or restrict the type of, the records a user requests for download, allowing users with the instructor role to retrieve the full content and metadata of arbitrary posts, including other instructors' private and draft courses.

References

Community reviews

Loading reviews…