CVE-2026-82912: Apache OFBiz · Expression Language Injection
Affects Apache OFBizSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 24.09.08 soon.
Data as of 5 Nov 2026, 16:04 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 8.8 |
|---|
- Patch
- Available – fixed in 24.09.08
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade Apache OFBiz to 24.09.08.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache OFBiz | Affected
| Fixed in
|
AI-suggested
Upgrade Apache OFBiz to version 24.09.08 or later, which contains the official fix for this vulnerability. No other mitigations are indicated by the vendor advisory.
Description
Improper Neutralization of Special Elements Used in an Expression Language Statement ('Expression Language Injection') in EmailServices in Apache OFBiz 24.09 before 24.09.08 on all platforms allows a remote authenticated attacker holding only OFBTOOLS_VIEW and ACCOUNTING_VIEW, the two view-level permissions that open the Accounting application, to execute arbitrary operating system commands as the account running OFBiz, by submitting a ${groovy:...} expression as the bodyText or subject value to the shipped Send Per Email invoice form, because sendMailFromScreen passes those caller-supplied values through FlexibleStringExpander.expandString, which compiles and evaluates embedded Groovy on a class loader that carries none of the SecureASTCustomizer restrictions GroovyUtil.eval applies elsewhere, behind a service and request-map that declare no permission check beyond base authentication. Users are recommended to upgrade to version 24.09.08, which fixes this issue.