Skip to main content
VulnerabilityPublished

CVE-2026-95664: Apache Camel · Expression Language Injection

Affects Apache CamelSource CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium : upgrade to 4.22.2 or 4.18.5 when convenient.

Data as of 26 Oct 2026, 14:18 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.22.2, 4.18.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache to 4.22.2 or 4.18.5.

Affected software

ProductAffectedFixed in
Apache Camelorg.apache.camel:camel-aws2-s3Affected
  • >=4.19.0 <4.22.2
Fixed in
  • 4.22.2
Apache Camelorg.apache.camel:camel-aws2-s3Affected
  • >=4.8.0 <4.18.5
Fixed in
  • 4.18.5
MavenApache Software Foundation/org.apache.camel:camel-aws2-s3pkg:maven/Apache Software Foundation/org.apache.camel:camel-aws2-s3Other threatsAffected
  • >=4.8.0 <4.18.5
  • >=4.19.0 <4.22.2
Fixed in
  • 4.18.5
  • 4.22.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Apache Camel versions 4.18.5, 4.22.2, and later (including 4.23.0). Users should upgrade to one of these versions to resolve the vulnerability. For users unable to upgrade immediately, it is recommended to prevent untrusted keys from reaching the aws2-s3 producer by removing the CamelAwsS3Key header before the producer or rejecting exchanges where the header contains '${' or '$simple{'. Configuring the keyName option alone is not sufficient because the header takes precedence. Additionally, restrict write permissions on buckets consumed by Camel routes to trusted principals only. After upgrading, any expressions in headers must be explicitly evaluated within the route using safe methods.

Description

CVE-2026-95664 is an Expression Language Injection vulnerability in the Apache Camel AWS2-s3 component affecting versions from 4.8.0 before 4.18.5 and from 4.19.0 before 4.22.2. The issue arises because the key used by the aws2-s3 producer is taken from a message header and evaluated as a Simple language expression if it contains certain markers, allowing untrusted input to be executed. This can lead to unauthorized access to JVM system properties, environment variables, and invocation of methods on beans, potentially exposing sensitive information. The vulnerability is fixed in versions 4.18.5 and 4.22.2. Users are advised to upgrade to these versions or 4.23.0 or later. Workarounds include removing or validating the CamelAwsS3Key header to prevent untrusted expressions from being evaluated.

References

Community reviews

Loading reviews…