Skip to main content
VulnerabilityPublished

CVE-2026-82960: Apache OFBiz · Code Injection

Affects Apache OFBizSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 24.09.08 soon.

Data as of 5 Nov 2026, 16:04 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.18.8
Patch
Available – fixed in 24.09.08
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Apache OFBiz to 24.09.08.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache OFBizAffected
  • <24.09.08
Fixed in
  • 24.09.08

AI-suggested

Users should upgrade Apache OFBiz to version 24.09.08 or later, which contains the fix for this code injection vulnerability. No other mitigations are indicated by the vendor advisory.

Description

Improper Control of Generation of Code ('Code Injection') in ModelFormField in the Apache OFBiz cms plugin before 24.09.08 on all platforms allows a remote authenticated attacker holding only CMS content-editor access to execute arbitrary operating system commands as the OFBiz process user via a single HTTP POST request, by submitting a crafted caContentIdTo parameter to EditAddContent, because the CMS screen copies that parameter into a top-level context variable that is interpolated into a form field's use-when attribute and the resulting string is passed unvalidated to GroovyUtil.eval(), whose compile-time SecureASTCustomizer sandbox does not restrict runtime reflection, allowing a payload that closes the expanded string literal and invokes java.lang.Runtime via reflection. Users are recommended to upgrade to version 24.09.08, which fixes this issue.

References

Community reviews

Loading reviews…