CVE-2026-8305: OpenClaw · Improper Authentication
Affects OpenClawSource CVE Database V5
Public exploit available · CVSS 6.9 Medium.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 11 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenClaw | Affected
| Fixed in– |
GitHubopenclaw/openclawpkg:github/openclaw/openclawOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the affected OpenClaw component to version 2026.2.12 or later, which contains the official fix for this vulnerability. Applying this update fully mitigates the risk. Patch status is confirmed by the vendor advisory indicating the fix is included in version 2026.2.12.
Description
A vulnerability was detected in OpenClaw up to 2026.1.24. The impacted element is the function handleBlueBubblesWebhookRequest of the file extensions/bluebubbles/src/monitor.ts of the component bluebubbles Webhook. Performing a manipulation results in improper authentication. It is possible to initiate the attack remotely. The exploit is now public and may be used. Upgrading to version 2026.2.12 is sufficient to resolve this issue. The patch is named a6653be0265f1f02b9de46c06f52ea7c81a836e6. The affected component should be upgraded.
References
- vuldb.com/vuln/362590 (opens in a new tab)
- vuldb.com/vuln/362590/cti (opens in a new tab)
- vuldb.com/submit/809371 (opens in a new tab)
- github.com/openclaw/openclaw/issues/13786 (opens in a new tab)
- github.com/openclaw/openclaw/pull/13787 (opens in a new tab)
- github.com/Dave-gilmore-aus/security-advisories/blob/main/ClawdBot(aka%20OpenClaw)-Auth-Bypass-SSRF (opens in a new tab)
- github.com/openclaw/openclaw/commit/a6653be0265f1f02b9de46c06f52ea7c81a836e6 (opens in a new tab)
- github.com/openclaw/openclaw/releases/tag/v2026.2.12 (opens in a new tab)
- github.com/openclaw/openclaw/ (opens in a new tab)