Skip to main content
VulnerabilityPublished

CVE-2026-84098: Directorist: AI-Powered Business Directory, Listings & Classified Ads (WordPress plugin) · Incorrect Authorization

Affects Directorist: AI-Powered Business Directory, Listings & Classified Ads (WordPress plugin)Source CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 6.5 Medium : upgrade to 8.9.5 when convenient.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.9.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade Directorist: AI-Powered Business Directory, Listings & Classified Ads (WordPress plugin) to 8.9.5.

Affected software

ProductAffectedFixed in
Directorist: AI-Powered Business Directory, Listings & Classified AdsAffected
  • >=3.1.0 <8.9.5
Fixed in
  • 8.9.5

AI-suggested

Upgrade the Directorist plugin to version 8.9.5 or later, where the vulnerability is fixed. No other mitigation or workaround is indicated. Patch status is confirmed by the version range provided, indicating 8.9.5 contains the fix.

Description

The Directorist: AI-Powered Business Directory, Listings & Classified Ads WordPress plugin before 8.9.5 does not properly verify a listing's ownership before deleting it, allowing authenticated attackers with Subscriber-level access and above to delete arbitrary listings, including ones belonging to other users. This is an incomplete fix of CVE-2023-1889 / CVE-2023-35052: a separate, unaddressed listing-deletion path allows the same impact, from at least version 3.1.0 through the current release.

References

Community reviews

Loading reviews…