Skip to main content
VulnerabilityPublished

CVE-2026-84742: The Events Calendar (WordPress plugin) · Incorrect Authorization

Affects The Events Calendar (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.7 Low : upgrade to 6.17.5 when convenient.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 3.1 base score
2.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.17.5
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade The Events Calendar (WordPress plugin) to 6.17.5.

Affected software

ProductAffectedFixed in
The Events CalendarAffected
  • >=6.15.0 <6.17.5
Fixed in
  • 6.17.5

AI-suggested

A fix is available in The Events Calendar plugin version 6.17.5. Users should upgrade to version 6.17.5 or later to remediate this vulnerability.

Description

The Events Calendar WordPress plugin before 6.17.5 does not check the capability required to publish content before creating or updating it through its REST API, allowing users with a role that cannot normally publish, such as contributor, to publish content directly and bypass editorial review.

References

Community reviews

Loading reviews…