CVE-2026-85295: chartbrew · Use of Default Cryptographic Key
Affects chartbrewSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 5.2.3 as a priority.
Data as of 6 Nov 2026, 21:19 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 9.8 |
|---|
- Patch
- Available – fixed in 5.2.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade chartbrew to 5.2.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| chartbrewchartbrew | Affected
| Fixed in
|
AI-suggested
Upgrade Chartbrew to version 5.2.3 or later, where this vulnerability is fixed. Avoid using default, weak, or known CB_SECRET values in deployments. For existing deployments, ensure CB_SECRET is set to a strong, unique secret. No other mitigations are indicated as the fix is official and complete.
Description
Chartbrew versions prior to 5.2.3 contain a critical vulnerability where default, weak, or known cryptographic keys (CB_SECRET) are used to sign session tokens. This allows attackers to forge HS256 tokens to impersonate any user without needing their password or two-factor authentication. The vulnerability affects the session JWT fallback verification in multiple server modules and impacts deployments using default or weak CB_SECRET values. The issue is fixed in version 5.2.3.