CVE-2026-86784: Visualizer (WordPress plugin) · Cross-Site Scripting (XSS)
Affects Visualizer (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.8 Medium : upgrade to 4.0.8 when convenient.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.8
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Visualizer (WordPress plugin) to 4.0.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Visualizer | Affected
| Fixed in
|
AI-suggested
Upgrade the Visualizer plugin to version 4.0.8 or later where this vulnerability is fixed. No other mitigation guidance is provided. Patch status is confirmed by the version boundary indicating the fix in 4.0.8.
Description
CVE-2026-86784 is a cross-site scripting (XSS) vulnerability in the Visualizer WordPress plugin versions before 4.0.8. It occurs because the plugin does not properly sanitize and escape JSON data used for chart configurations in the chart editor. This allows users with Contributor role or higher to inject JavaScript that executes in the browsers of higher-privileged users, such as administrators, when they view the affected chart.