CVE-2026-87022: Apache Tomcat · Improper Handling of Length Parameter Inconsistency
Affects Apache TomcatSource CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 11.0.26 : patch Apache Tomcat soon.
Data as of 6 Nov 2026, 23:24 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 11.0.26
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Tomcat | Affected
| Fixed in– |
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade affected Apache Tomcat versions to 11.0.26, 10.1.60, or 9.1.22, where the vulnerability has been fixed. Applying these official updates is the recommended and effective mitigation. No additional vendor advisories indicate alternative mitigations or that no action is required.
Description
CVE-2026-87022 is a high-severity vulnerability in Apache Tomcat involving improper handling of length parameter inconsistencies when using per-message-deflate in WebSocket communications. This flaw allows WebSocket message smuggling, potentially enabling attackers to interfere with message integrity. The vulnerability affects multiple versions of Apache Tomcat, including 11.0.0-M1 through 11.0.25, 10.1.0-M1 through 10.1.59, 9.0.0.M1 through 9.0.121, and some older end-of-support versions. Fixed versions are available, and users are advised to upgrade to 11.0.26, 10.1.60, or 9.1.22 to mitigate the issue.