Skip to main content
VulnerabilityPublished Updated

CVE-2026-8709: Progress Software MarkLogic Server · Improper Privilege Management

Affects Progress Software MarkLogic ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.9 Critical : upgrade to 12.0.3 or 11.3.6 as a priority.

Data as of 3 Nov 2026, 22:58 UTC

CVSS 3.1 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 12.0.3, 11.3.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade Progress Software MarkLogic Server to 12.0.3 or 11.3.6.

Affected software

ProductAffectedFixed in
Progress Software CorporationMarkLogic ServerAffected
  • >=12.0.0 <12.0.3
Fixed in
  • 12.0.3
Progress Software CorporationMarkLogic ServerAffected
  • >=11.0.0 <11.3.6
Fixed in
  • 11.3.6

AI-suggested

If you cannot patch yet, restrict REST API access to trusted users only and monitor for unusual privilege escalation attempts. Follow vendor communications closely for updates on patches or official mitigations.

Description

CVE-2026-8709 is a critical improper privilege management vulnerability in Progress Software Corporation's MarkLogic Server. It affects the REST API document patch operation in versions 11.0.0 and 12.0.0, allowing an authenticated user with a low-privileged REST role to escalate privileges and perform privileged operations on the Security database. The vulnerability has a CVSS score of 9.9, indicating a severe impact on confidentiality, integrity, and availability.

References

Community reviews

Loading reviews…