Skip to main content
VulnerabilityPublished

CVE-2026-87785: Apache Syncope · Authentication Bypass by Spoofing

Affects Apache SyncopeSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical · fixed in 4.0.8 : patch Apache Syncope as a priority.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache SyncopeAffected
  • >=3.0.0-M0 <=3.0.16
  • >=4.0.0-M0 <=4.0.7
  • >=4.1.0-M0 <=4.1.2
Fixed in–
MavenApache Software Foundation/org.apache.syncope.core:syncope-core-springpkg:maven/Apache Software Foundation/org.apache.syncope.core:syncope-core-springOther threatsAffected
  • >=3.0.0-M0 <=3.0.16
  • >=4.0.0-M0 <=4.0.7
  • >=4.1.0-M0 <=4.1.2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Syncope to version 4.0.8 or 4.1.3, where this vulnerability is fixed. No other mitigations are specified. Applying the official fix fully addresses the issue.

Description

Authentication bypass by spoofing vulnerability in Apache Syncope. When the configured JWKS settings for internal JWT authentication are disclosed (at least protocol and key), an attacker can spoof another user's privileges after completing a successful authentication and obtaining a valid JWT. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.

References

Community reviews

Loading reviews…