CVE-2026-87802: Apache Syncope · Improper Verification of Cryptographic Signature
Affects Apache SyncopeSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical · fixed in 4.0.8 : patch Apache Syncope as a priority.
Data as of 29 Oct 2026, 14:41 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Syncope | Affected
| Fixed in– |
MavenApache Software Foundation/org.apache.syncope:syncope-srapkg:maven/Apache Software Foundation/org.apache.syncope:syncope-sraOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Syncope to version 4.0.8 or 4.1.3, which contain fixes for this vulnerability. Proper configuration of the Syncope Reverse Proxy to include a JWKS set URI for OAuth 2.0 is also essential to prevent exploitation.
Description
Improper verification of cryptographic signature vulnerability in Apache Syncope. When SRA is configured for OAuth 2.0 without JWKS set URI assigned, an attacker can forge arbitrary JWTs to impersonate any user identity and permissions, gaining full access to services proxied by SRA. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.