CVE-2026-87919: Product XML Feed Manager for WooCommerce (WordPress plugin) · Missing Authorization
Affects Product XML Feed Manager for WooCommerce (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 4.9 Medium : upgrade to 3.1.1 when convenient.
Data as of 27 Oct 2026, 17:11 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Product XML Feed Manager for WooCommerce (WordPress plugin) to 3.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Product XML Feed Manager for WooCommerce | Affected
| Fixed in
|
AI-suggested
Upgrade the Product XML Feed Manager for WooCommerce plugin to version 3.1.1 or later, where this authorization issue is fixed. Until then, restrict contributor-level access or avoid previewing posts containing the product shortcode to mitigate risk.
Description
The Product XML Feed Manager for WooCommerce WordPress plugin before 3.1.1 does not restrict which object method its product shortcode may call, nor check the user's capability over the targeted product, allowing users with contributor-level access to delete arbitrary WooCommerce products by previewing a post that contains the shortcode.