CVE-2026-58255: jhuckaby Cronicle · Improper Privilege Management
Affects jhuckaby CronicleSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.8 High : upgrade to 0.9.121 soon.
Data as of 27 Oct 2026, 22:57 UTC
- Patch
- Available – fixed in 0.9.121
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Cronicle and jhuckaby/Cronicle to 0.9.121.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| jhuckabyCronicle | Affected
| Fixed in
|
GitHubjhuckaby/Croniclepkg:github/jhuckaby/CronicleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Cronicle to version 0.9.121 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory.
Description
CVE-2026-58255 is a privilege management vulnerability in jhuckaby Cronicle versions prior to 0.9.121. It allows a non-administrator user or scoped API key with certain privileges to inject arbitrary user and group IDs into scheduled jobs via the event creation or update API endpoints. This flaw enables low-privileged users on root-daemon installations to run jobs as arbitrary users, including root, bypassing intended access controls. The issue is fixed in version 0.9.121.