CVE-2026-87965: Easy Appointments (WordPress plugin) · Improper Access Control
Affects Easy Appointments (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 4.8 Medium : upgrade to 4.0.2.2 when convenient.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.2.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 18 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade Easy Appointments (WordPress plugin) to 4.0.2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Easy Appointments | Affected
| Fixed in
|
AI-suggested
Upgrade Easy Appointments to version 4.0.2.2 or later, where this vulnerability is fixed. The vendor advisory indicates that versions before 4.0.2.2 are affected, so applying the official update is the recommended remediation.
Description
The Easy Appointments WordPress plugin before 4.0.2.2 does not use an unguessable token to authorize its mail-link appointment cancellation and confirmation action, deriving the token from a hardcoded source-embedded salt and the appointment's creation timestamp, so unauthenticated attackers who know or guess that timestamp can cancel or confirm arbitrary appointments.