CVE-2026-88022: Laravel MongoDB (PHP) · Improper Neutralization of Special Elements in Data Query Logic
Affects Laravel MongoDB (PHP)Source CVE Database V5
Not known to be exploited · CVSS 8.4 High : upgrade to 5.11.0 soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-09-10.
- Patch
- Available – fixed in 5.11.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Laravel MongoDB (PHP) to 5.11.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MongoDBLaravel MongoDB (PHP) | Affected
| Fixed in
|
AI-suggested
Upgrade the Laravel MongoDB integration to version 5.11.0 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated by the vendor advisory. Applying the official fix fully addresses the issue.
Description
CVE-2026-88022 is a high-severity vulnerability in the MongoDB integration for Laravel (PHP) that improperly neutralizes special elements in data query logic. This flaw affects the three-argument where method when using the '=' or 'eq' operator, as well as the find and delete methods that rely on this code path. An attacker able to supply an operator-shaped array to these APIs may cause the application to return or delete documents beyond the intended target. The issue is fixed in version 5.11.0.