Skip to main content
VulnerabilityPublished

CVE-2026-88027: Laravel MongoDB (PHP) · Improper Neutralization of Special Elements in Data Query Logic

Affects Laravel MongoDB (PHP)Source CVE Database V5

0

Not known to be exploited · CVSS 7.1 High : upgrade to 5.11.0 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-09-10.

Patch
Available – fixed in 5.11.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Laravel MongoDB (PHP) to 5.11.0.

Affected software

ProductAffectedFixed in
MongoDBLaravel MongoDB (PHP)Affected
  • >=4.0.0 <5.11.0
Fixed in
  • 5.11.0

AI-suggested

Upgrade affected installations of Laravel MongoDB integration to version 5.11.0 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated by the vendor advisory. Applying the official fix fully addresses the issue.

Description

CVE-2026-88027 is a vulnerability in the MongoDB integration for Laravel PHP framework versions 4.0.0 up to but not including 5.11.0. It involves improper neutralization of special elements in data query logic within the embedded-document relation handling. This flaw allows an authenticated user who can influence an embedded record identifier to have that identifier interpreted as a query condition instead of a literal identifier. As a result, the attacker may delete all embedded documents in a targeted record or overwrite an embedded document other than the intended target. The vulnerability has a high severity with a CVSS score of 7.1. A fix is available in version 5.11.0.

References

Community reviews

Loading reviews…