Skip to main content
VulnerabilityPublished

CVE-2026-88811: SUSE Rancher · Insertion of Sensitive Information Into Sent Data

Affects SUSE RancherSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical · fixed in 2.15.3 : patch SUSE Rancher as a priority.

Data as of 2 Nov 2026, 17:43 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (suse)CVSS 3.19.1
Patch
Available – fixed in 2.15.3, 2.14.7, 2.13.11 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
SUSERancherAffected
  • >=2.15.0 <2.15.3
Fixed in
  • 2.15.3
SUSERancherAffected
  • >=2.14.0 <2.14.7
Fixed in
  • 2.14.7
SUSERancherAffected
  • >=2.13.0 <2.13.11
Fixed in
  • 2.13.11
SUSERancherAffected
  • >=2.12.0 <2.12.15
Fixed in
  • 2.12.15
SUSERancherAffected
  • >=2.11.0 <2.11.19
Fixed in
  • 2.11.19
GitHubRancherpkg:github/RancherOther threatsAffected
  • >=2.15.0 <2.15.3
  • >=2.14.0 <2.14.7
  • >=2.13.0 <2.13.11
  • >=2.12.0 <2.12.15
  • >=2.11.0 <2.11.19
Fixed in
  • 2.15.3
  • 2.14.7
  • 2.13.11
  • 2.12.15
  • 2.11.19

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions are available and should be applied: 2.15.3, 2.14.7, 2.13.11, 2.12.15, and 2.11.19. Users should upgrade affected SUSE Rancher installations to these versions to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

Missing filtering in the SUSE Rancher Manager meta proxy could cause passed in rancher credentials to be leaked to cloud providers. This affects SUSE Rancher 2.15.0 up to 2.15.3, 2.14.0 up to 2.14.7, 2.13.0 up to 2.13.11,

References

Community reviews

Loading reviews…