Skip to main content
VulnerabilityPublished Updated

CVE-2026-88922: HashiCorp Shared library · Improper Preservation of Permissions

Affects HashiCorp Shared librarySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.7 Medium : upgrade to 2.2.4 when convenient.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
6.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2.4, 1.8.9
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Shared to 2.2.4 (library) or 1.8.9 (library).

Affected software

ProductAffectedFixed in
HashiCorpShared libraryAffected
  • >=1.0.1 <1.8.9
Fixed in
  • 2.2.4
GitHubShared librarypkg:github/Shared libraryOther threatsAffected
  • >=1.0.1 <1.8.9
Fixed in
  • 1.8.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the go-getter library to version 1.8.9 or later, or 2.2.4 or later, where this vulnerability has been fixed. No other mitigation is required as the issue is resolved in these versions.

Description

The go-getter library up to versions 1.8.8 and 2.2.3 is vulnerable to a privilege escalation issue in its archive decompression handling that may allow a crafted archive to cause extracted files to be created with elevated permission bits. Where extraction is performed by a privileged user, this may allow a local actor to obtain the privileges of the extracting process. This vulnerability (CVE-2026-88922) is fixed in go-getter 1.8.9 and 2.2.4.

References

Community reviews

Loading reviews…