Skip to main content
VulnerabilityPublished Updated

CVE-2026-89027: miniOrange JWT Authentication for WP REST APIs · Missing Authentication

Affects miniOrange JWT Authentication for WP REST APIsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 4.8.0 when convenient.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.8.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade miniOrange JWT Authentication for WP REST APIs to 4.8.0.

Affected software

ProductAffectedFixed in
miniOrangeJWT Authentication for WP REST APIsAffected
  • <4.8.0
Fixed in
  • 4.8.0

AI-suggested

A fixed version 4.8.0 or later should be applied to remediate this vulnerability. Since the affected versions are prior to 4.8.0, upgrading the plugin to version 4.8.0 or newer will address the issue. Patch status is confirmed by the version boundary in affectedVersions.

Description

miniOrange JWT Authentication for WP REST APIs plugin for WordPress before 4.8.0 contains an authentication method downgrade vulnerability that allows unauthenticated attackers to bypass administrator-configured authentication by supplying a specific GET parameter without any capability check or nonce verification. Attackers can force the plugin to use Basic HTTP authentication regardless of configured JWT or API token settings, then exploit distinguishable error codes and the absence of rate limiting to perform unthrottled username enumeration and credential guessing attacks.

References

Community reviews

Loading reviews…