Skip to main content
VulnerabilityPublished Updated

CVE-2026-89162: PCRE PCRE2 · Incorrect Resource Transfer Between Spheres

Affects PCRE PCRE2Source CVE Database V5

0

Not known to be exploited · CVSS 2.9 Low : upgrade to 10.48 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
2.9Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.48
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade PCRE2 and pcre2project/pcre2 to 10.48.

Affected software

ProductAffectedFixed in
PCREPCRE2Affected
  • >=10.45 <10.48
Fixed in
  • 10.48
GitHubpcre2project/pcre2pkg:github/pcre2project/pcre2Other threatsAffected
  • >=10.45 <10.48
Fixed in
  • 10.48

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Until a fix is confirmed, avoid running vulnerable versions in environments where local untrusted users have access.

Description

CVE-2026-89162 is a medium severity vulnerability in PCRE2 versions 10.45 up to but not including 10.48. It involves an incorrect resource transfer issue in the pcre2_serialize_encode function that may disclose two bytes of information to an adversary. This typically occurs in scenarios where the adversary already has unsafe access. The vulnerability does not affect integrity or availability and requires local access with high attack complexity.

References

Community reviews

Loading reviews…