Skip to main content
VulnerabilityPublished

CVE-2026-89278: GPTranslate (WordPress plugin) · Information Exposure

Affects GPTranslate (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium · patch available : update GPTranslate (WordPress plugin) when convenient.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
john-dagelmoreGPTranslate – Multilingual AI Translation Agent for WordPress: Translate Your Site with AIAffected
  • <=2.34.6
Fixed in–

AI-suggested

A patch is available for this vulnerability. Users should update the GPTranslate plugin to a fixed version beyond 2.34.6. Alternatively, configuring the plugin to use server-proxy mode or DeepSeek models prevents API key exposure. No additional mitigation is required if these configurations are already in use.

Description

The GPTranslate – Multilingual AI Translation Agent for WordPress: Translate Your Site with AI plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.34.6 via the enqueue_frontend_scripts. This makes it possible for unauthenticated attackers to extract the plaintext third-party AI provider API key (OpenAI, DeepL, xAI/Grok, Gemini, Claude, or Google Cloud Translation) — a credential granting billed account access — by fetching any public page and applying the inverse transformation bundled in the plugin's own public JavaScript asset. This exposure affects the default configuration (gpt-3.5-turbo in client mode) and all supported non-DeepSeek providers; only deepseek-* models and gpt-* models configured in server-proxy mode correctly suppress key emission.

References

Community reviews

Loading reviews…