Skip to main content
VulnerabilityPublished

CVE-2026-89292: Eclipse Mnestix · Server-Side Request Forgery

Affects Eclipse MnestixSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.2 Critical : upgrade to 2.3.0 as a priority.

Data as of 3 Nov 2026, 09:43 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (eclipse)CVSS 4.09.2
Patch
Available – fixed in 2.3.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Eclipse Mnestix to 2.3.0.

Affected software

ProductAffectedFixed in
Eclipse FoundationEclipse MnestixAffected
  • >=1.6.0 <2.3.0
Fixed in
  • 2.3.0

Description

In Eclipse Mnestix Browser versions 1.6.0 up until but excluding 2.3.0 it was possible for an unauthenticated attacker to exfiltrate the MNESTIX_BACKEND_API_KEY for all configured Infrastructures.

References

Community reviews

Loading reviews…