CVE-2026-8935: WP MAPS PRO · Improper Privilege Management
Affects WP MAPS PROSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 6.1.1 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.1.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 15 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade WP MAPS PRO to 6.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| WP MAPS PRO | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to frontend pages that enqueue the vulnerable map script or disable the WP MAPS PRO plugin.
Description
CVE-2026-8935 is a critical vulnerability in the WP MAPS PRO WordPress plugin before version 6.1.1. It involves improper privilege management where an unauthenticated AJAX action, combined with a publicly available nonce, allows creation of an administrator account and grants interactive admin access via a magic-login URL. This vulnerability enables full administrative control without authentication.