CVE-2026-90781: alsa-lib · Off-by-one Error
Affects alsa-libSource CVE Database V5
Not known to be exploited · CVSS 4.8 Medium · fixed in 1.2.16.1 : update alsa-lib when convenient.
Data as of 29 Oct 2026, 07:15 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.2.16.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ALSA Projectalsa-lib | Affected
| Fixed in– |
GitHubalsa-libpkg:github/alsa-libOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in versions later than 1.2.16.1. Users should upgrade alsa-lib to a version newer than 1.2.16.1 to remediate this vulnerability. Until then, avoid processing untrusted control-element identifier strings with 64 or more characters.
Description
CVE-2026-90781 is a medium severity vulnerability in alsa-lib, a library interfacing with ALSA in the Linux kernel. It involves a stack buffer overflow caused by an off-by-one error in the __snd_ctl_ascii_elem_id_parse() function when parsing a name= field with 64 or more characters. This overflow allows overwriting one byte past a 64-byte buffer, potentially crashing the calling process. The flaw affects alsa-lib versions up to and including 1.2.16.1.
References
- github.com/alsa-project/alsa-lib/commit/f84cd4ced7b36fddb8e4ee24404cf7c091d27020 (opens in a new tab)
- github.com/alsa-project/alsa-lib/blob/v1.2.16.1/src/control/ctlparse.c (opens in a new tab)
- lore.kernel.org/alsa-devel/CACBQ=P2FhO3M6dkv3cWuKb6Qhs92ouV+FJ3SJZ_PVBSSdJWRAQ@mail.gmail.com/ (opens in a new tab)
- github.com/alsa-project/alsa-lib (opens in a new tab)
- vulncheck.com/advisories/alsa-lib-through-1.2.16.1-off-by-one-stack-buffer-overflow-in-snd-ctl-ascii-elem-id-parse (opens in a new tab)