Skip to main content
VulnerabilityPublished Updated

CVE-2026-91942: unclecode crawl4ai · Cross-site Scripting

Affects unclecode crawl4aiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.1 Medium : upgrade to 0.9.3 when convenient.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade crawl4ai and unclecode/crawl4ai to 0.9.3.

Affected software

ProductAffectedFixed in
unclecodecrawl4aiAffected
  • <0.9.3
Fixed in
  • 0.9.3
GitHubunclecode/crawl4aipkg:github/unclecode/crawl4aiOther threatsAffected
  • <0.9.3
Fixed in
  • 0.9.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version 0.9.3 or later should be used to remediate this vulnerability. Since the affected versions are prior to 0.9.3, upgrading to 0.9.3 or above is recommended. No vendor advisory or patch link was provided, so verify the availability of the fix from the vendor or official sources before deployment.

Description

crawl4ai before 0.9.3 contains a DOM-based cross-site scripting vulnerability in the Docker Playground UI that assigns untrusted crawl results to element.innerHTML. Attackers can craft malicious PDFs with event-handler markup to execute JavaScript in the Playground origin and steal API tokens from sessionStorage for authenticated API abuse.

References

Community reviews

Loading reviews…