Skip to main content
VulnerabilityPublished

CVE-2026-92098: Webheadcoder Multi-Step Forms for Contact Form 7 (WordPress plugin) · Cross-site Scripting

Affects Webheadcoder Multi-Step Forms for Contact Form 7 (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium.

Data as of 28 Oct 2026, 07:12 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
webheadllcWebheadcoder Multi-Step Forms for Contact Form 7Affected
  • <=4.7
Fixed in–

AI-suggested

Users should upgrade beyond version 4.7 if a fixed version becomes available or apply vendor-provided patches once released. Until then, avoid using multistep forms or restrict access to vulnerable parameters. Monitor vendor advisories for updates. Since the vulnerability requires user interaction and specific form configuration, limiting exposure can reduce risk.

Description

The Webheadcoder Multi-Step Forms for Contact Form 7 WordPress plugin versions up to and including 4.7 are vulnerable to reflected Cross-Site Scripting (XSS) via the 'l10n_print_after' parameter. This vulnerability allows unauthenticated attackers to inject arbitrary scripts that execute when a user interacts with a crafted link. Exploitation requires the targeted site to have at least one Contact Form 7 form configured with a [multistep] form-tag. The vulnerability is mitigated in non-multistep forms starting from version 4.7 due to canonicalization blocking the attack path.

References

Community reviews

Loading reviews…