Skip to main content
VulnerabilityPublished Updated

CVE-2026-92627: The HDF Group HDF5 · Use After Free

Affects The HDF Group HDF5Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.6 Medium : upgrade to 1.14.2 when convenient.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 4.0 base score
4.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.14.2
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade The HDF Group HDF5 to 1.14.2.

Affected software

ProductAffectedFixed in
The HDF GroupHDF5Affected
  • <1.14.2
Fixed in
  • 1.14.2

AI-suggested

A fix is available in HDF5 version 1.14.2 and later. Users and administrators should upgrade to version 1.14.2 or newer to remediate this vulnerability. Until patched, avoid opening untrusted HDF5 files with affected versions. No vendor advisory content was provided, so check the official HDF Group resources for the latest remediation guidance.

Description

CVE-2026-92627 is a heap-use-after-free vulnerability in the HDF5 library before version 1.14.2. It occurs during the conversion of compound datatypes containing floating-point members when reading datasets. An attacker can craft a malicious HDF5 file that triggers this vulnerability, potentially causing application crashes or memory corruption. The vulnerability has a medium severity score of 4.6 and affects local attack vectors with low complexity and no privileges required but requires user interaction.

References

Community reviews

Loading reviews…