CVE-2026-92771: twentyhq twenty · Incorrect Authorization
Affects twentyhq twentySource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 2.35.0 soon.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.35.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade twenty and twentyhq/twenty to 2.35.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| twentyhqtwenty | Affected
| Fixed in
|
GitHubtwentyhq/twentypkg:github/twentyhq/twentyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to twenty version 2.35.0 or later where this authorization issue is fixed. Since the vendor advisory is not provided, patch status is inferred from the affectedVersions field indicating versions before 2.35.0 are vulnerable and presumably fixed in 2.35.0. No additional mitigation guidance is available from the input data.
Description
Twenty before 2.35.0 fails to validate field and row permissions in the groupBy-with-records GraphQL resolver, allowing authenticated users to bypass permission checks. Attackers with canReadObjectRecords permission but canReadFieldValue false can retrieve restricted field values through the groupBy resolver that would normally be denied.
References
- github.com/twentyhq/twenty/issues/25911 (opens in a new tab)
- github.com/twentyhq/twenty (opens in a new tab)
- github.com/twentyhq/twenty/blob/twenty/v2.14.0/packages/twenty-server/src/engine/twenty-orm/repository/permissions.utils.ts (opens in a new tab)
- github.com/twentyhq/twenty/blob/twenty/v2.14.0/packages/twenty-server/src/engine/api/graphql/graphql-query-runner/group-by/services/group-by-with-records.service.ts (opens in a new tab)
- vulncheck.com/advisories/twenty-before-2.35.0-permission-bypass-via-groupby-with-records-query (opens in a new tab)