CVE-2026-92773: triggerdotdev trigger.dev · Insecure Direct Object Reference
Affects triggerdotdev trigger.devSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 4.6.0 soon.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.6.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:H/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade trigger.dev and triggerdotdev/trigger.dev to 4.6.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| triggerdotdevtrigger.dev | Affected
| Fixed in
|
GitHubtriggerdotdev/trigger.devpkg:github/triggerdotdev/trigger.devOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in trigger.dev version 4.6.0. Users should upgrade to version 4.6.0 or later to remediate this vulnerability. No additional mitigation steps are indicated.
Description
Trigger.dev versions before 4.6.0 contain an authorization bypass vulnerability where the application fails to verify that an authenticated user controls a GitHub App installation before associating it with their organization. This flaw allows attackers to claim another user's GitHub App installation by replaying state cookies and using sequential installation IDs, potentially gaining unauthorized access to the victim's repositories.
References
- github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-9rx3-j5hm-5f27 (opens in a new tab)
- github.com/triggerdotdev/trigger.dev/blob/v4.5.16/apps/webapp/app/services/gitHub.server.ts (opens in a new tab)
- github.com/triggerdotdev/trigger.dev/blob/v4.6.0/apps/webapp/app/services/gitHub.server.ts (opens in a new tab)
- github.com/triggerdotdev/trigger.dev (opens in a new tab)
- vulncheck.com/advisories/trigger-dev-before-4.6.0-github-app-installation-takeover (opens in a new tab)