CVE-2026-93519: x.orgg xwayland · Heap-based Buffer Overflow
Affects x.orgg xwaylandSource CVE Database V5
Not known to be exploited · CVSS 7.8 High : upgrade to 24.1.14 soon.
Data as of 28 Oct 2026, 15:12 UTC
- Patch
- Available – fixed in 21.1.25, 24.1.14
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade xwayland to 24.1.14; xorg-x11-server and freedesktop/xorg/xserver to 21.1.25.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| x.orgxorg-x11-server | Affected
| Fixed in
|
| x.orggxwayland | Affected
| Fixed in
|
GitHubfreedesktop/xorg/xserverpkg:github/freedesktop/xorg/xserverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Fixed versions 21.1.25 for X.Org X server and 24.1.14 for XWayland are available and should be applied to remediate this vulnerability. No additional mitigation is indicated by the vendor advisory. Users should upgrade to these versions to ensure protection.
Description
CVE-2026-93519 is a heap-based buffer overflow vulnerability in the XFIXES extension handling of pointer barriers in X.Org X server versions before 21.1.25 and XWayland versions before 24.1.14. Authenticated X clients could exploit this flaw to crash the X server or potentially execute arbitrary code within the server context.