CVE-2026-93517: x.org xwayland · Heap-based Buffer Overflow
Affects x.org xwaylandSource CVE Database V5
Not known to be exploited · CVSS 8.5 High : upgrade to 24.1.14 soon.
Data as of 28 Oct 2026, 13:57 UTC
- Patch
- Available – fixed in 21.1.25, 24.1.14
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade xwayland to 24.1.14; xorg-x11-server to 21.1.25.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| x.orggxorg-x11-server | Affected
| Fixed in
|
| x.orgxwayland | Affected
| Fixed in
|
AI-suggested
Fixed versions 21.1.25 for X.org X server and 24.1.14 for XWayland are available and should be applied to remediate this vulnerability. Users should upgrade to these versions or later to eliminate the risk. No additional mitigations or workarounds are indicated.
Description
CVE-2026-93517 is a heap-based buffer overflow vulnerability in the X.org X server and XWayland. It occurs in the handling of the GLX RenderLarge request when dataBytes exceeds cmdlen. This flaw affects versions of X.org X server before 21.1.25 and XWayland before 24.1.14. An authenticated X client can trigger this vulnerability, potentially causing crashes or arbitrary code execution within the X server context.